Jira のトラブルシューティング (2)

Jira のトラブルシューティング (2)

はじめに

このページでは、すでに Jira をインストールしてご利用いただいている Jira システム管理者の方を対象に、よく発生するトラブルとその対応方法をご紹介します。
Jira のインストールが終わっていないときは、Jira インストールガイド を参考にインストールしてください。



Jira 管理画面の開き方

トラブルの対応方法を説明する前に、Jira の管理画面を開く方法を確認しておきます。

全体の管理画面

Jira に管理者ユーザーでログインします。画面の右上に歯車マーク

が表示されているのでクリックしてください。ユーザー確認のためパスワードの入力を求められることがあるので、そのときはパスワードを入力してください。

プロジェクトの管理画面

Jira に管理者ユーザーでログインし、管理したいプロジェクトを開きます。画面上部のメニューから「プロジェクト」をクリックし、管理したいプロジェクトをクリックします。



プロジェクトの詳細画面が表示されます。管理者ユーザーでログインしていると、左下に「プロジェクト設定」というリンクが表示されています。ここをクリックするとプロジェクトの管理画面が開きます。



次のようなプロジェクトの管理画面が表示されます。

アバターや画像が正しく表示されない

現象

ダッシュボード画面のアクティビティストリームなどに、アバターや画像が表示されなくなっていることがあります。また、一部のリンクもリンク切れになっています。

リンクをクリックすると、以下のようにリンク切れのページが表示されます。
(ブラウザとしてGoogle Chromeを使用した場合の例です) 

原因

原因を判断するためのポイントは、リンク切れページの表示内容にあります。「~では 127.0.0.1:8080 に接続できませんでした」と表示されています。このメッセージ内の 127.0.0.1:8080 は、通常はJIRAサーバを指すアドレス( jira.xxxxx.yy.zzなど)になりますが、ローカルホスト(自分自身)を指す特別なIPアドレス(127.0.0.1)になっています。
このため、クライアントPCなどJIRAサーバーの外側にあるマシンからはリソースを参照できず、画像が表示されなかったり、リンクが切れているなどの現象が発生します。

ご参考

127.0.0.1」ではなく「localhost」が使用されていることもあります。



対策

セットアップウィザードを実行したときにIPアドレス「127.0.0.1」(または「localhost」)を使用していたか、JIRAの設定を変更したときにベースURLの設定を誤って修正したことが原因と思われます。
以下の手順でベースURLの設定を確認してください。

  1. JIRAの管理画面を開く

  2. 「システム」の「一般設定」を開く。  

  3. 「設定」欄の「ベースURL」の内容を確認する

↑上の管理画面で「システム」の「一般設定」をクリックし、↓下の設定画面を開きます。

ベースURLに表示されている内容を確認してください。↑この画面の例では、自分自身を指す「127.0.0.1」というIPアドレスが設定されています。正しくは、JIRAサーバー外のコンピューターからアクセスできるURLを設定する必要があります。
どのようなURLを設定すればいいのかわからないときは、ネットワーク管理者にご相談ください。

設定を編集するには、画面の一番下にある「設定を編集」ボタンをクリックします。

↓下の画面のように設定値を編集できるようになるので、ベースURLの内容を正しいURLに変更してください。

変更できたら、画面の一番下にある「更新」ボタンをクリックして編集を確定します。

ベースURLを正しく設定できると、次の画面イメージのようにアバターなどの画像が表示され、リンク切れも発生しなくなります。

JIRAから通知メールが送信されない

JIRAには、新しい課題が報告されたり、既存の課題が変更されたりすると、関係するユーザーにメール通知する機能があります。
ただし、各ユーザーのメールアドレスを設定するだけでは使用できません。JIRAに利用できるメールサーバーの情報を設定し、プロジェクト単位にどのイベントに対してメールを送信するか指定する(通知スキームを指定する)必要があります。

使用するメールサーバーを設定する

JIRAの管理画面を開きます。右下の方にある「メール...」の「送信メール」をクリックして、電子メールサーバーの設定画面を開きます。

初めて設定画面を開いたときは、設定済みのサーバーは無いというメッセージが表示されています。「新規 SMTP メール サーバーの設定」ボタンをクリックします。

メールサーバーの設定画面が開きます。JIRAで使用したいメールサーバーの情報などを設定します。

入力項目のうち、最初の4項目はJIRAに固有の設定です。



内容

設定例

名前

JIRAの中でこのメールサーバーを識別するための名前です。任意の名前を指定してください。

通知メール送信用サーバー

説明

このメールサーバーに関する説明です。

JIRAからの通知メール送信に使用します。

送信元アドレス

JIRAから送信するメールの送信元として使用するアドレスです。

jira@dummy.com

メール プレフィックス

JIRAから送信するメールの件名の先頭に追加する識別子です。JIRAからのメールであることを見分けられるものにしてください。

[JIRA]

その他のメールサーバーの詳細設定は、ネットワーク管理者とご相談のうえ指定を行なってください。

リックソフト株式会社 は、日本でトップレベルのAtlassian Platinum Solution Partnerです。
大規模ユーザーへの対応実績が認められたEnterpriseの認定をうけ、高度なトレーニング要件をクリアし、小規模から大規模のお客様まで対応可能な実績を示したパートナー企業です。


Copyright © Ricksoft Co., Ltd. プライバシーポリシー お問い合わせ